
EECS 303: Advanced Digital Logic Design
Lab 1 - Mentor Graphics Tutorial

Robert Dick

Assigned: 25 September
Due: A week after the administrators open the lab for use

1 Introduction

This tutorial will introduce design simulation software from Mentor Graphics Corporation (MGC), running
on Solaris workstations in the Wilkinson Lab (Tech M338).

As you go through the tutorial, pay attention to how the steps you are carrying out can be generalized and
used in other ways. Part of your is to design and simulate an exclusive or gate. However, the most important
goal is to understand how to design and simulate an arbitrary circuit using the Mentor Graphics software
suite. Although it is possible to complete most tasks several different ways, diverging from the way given in
the tutorial may make it difficult for you to continue. Therefore, I recommend that you go through the lab
once, following the directions fairly closely. After you get things working, go back and try other alternatives,
i.e., play with the software to build an understanding of what it is capable of.

1.1 User interface

You need to know how to move, resize, iconify, and de-iconify X11 windows before you attempt this tutorial.
You may already be familiar with X11 from some of your previous classes: it is common to many Unix
platforms. If you have any minor questions, feel free to ask me, a TA, or other students. If you don’t have
a working knowledge of X11, get to Wilkinson soon and start practicing.

1.2 The Mentor Graphics Falcon Framework

The Mentor Graphics tools use Unix files and directories to represent schematics, simulations, and layouts.
All of these objects are logically linked together. Mentor provides a graphical tool called Design Manager
for viewing, moving, and copying design-related files while maintaining design integrity. Use of dmgr is not
optional. You must always use it when you want to move or copy designs. The use of native Unix commands
is not supported and if you rename, remove, or copy Mentor Graphics files using standard Unix commands,
you may corrupt your design beyond recovery.

MGC applications are large and can take a significant amount of time to perform certain tasks. Sometimes
it can be hard to tell if the application is busy or waiting. You can determine if the application is busy by
iconifying and de-iconifying the graphic window. If the application is not busy, it will repaint the window
immediately.

Occasionally, a MGC application will not respond to mouse clicks even though the tool is not doing anything.
If this happens, raise the window to the top of the desktop using the window manager.

Every time you open a new Mentor tool, such a simulator, viewpoint editor, schematic editor, etc., Mentor
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creates a new terminal window along with the graphical tool window. When you close the tool, Mentor does
not close the terminal window. You should close this manually to conserve system resources and to keep
your desktop clutter-free.

Tutorial format

This tutorial deals with the process of entering and simulating a design. It is structured as a sequence of
goals. Each goal is achieved by executing a combination of actions. Goals precede the actions needed to
achieve that goal. The actions which fulfill a goal are indented under the goal.

Text formatting is used to distinguish among goals, instructions, comments, and “commands” issued to the
software.

While you are working with this tutorial, make note of important steps and procedures, as you will need to
do these things repeatedly during the course of this class. Highlighting or underlining text may be useful.

2 Design Entry

Set up environment variables for MGC.

1. Log into one of the Solaris workstations in Wilkinson.
We don’t cover how to do this here; if you don’t know how, ask the TA. It is also possible to run the
tools remotely from a PC using an X server under windows, or Linux (see the appendix).

2. Start a shell by clicking the left mouse button (LMB) and choosing the “New window” option.

3. Source the mentor environment variables required to run the tool by typing

source /vol/ece303/mgc.env

at the prompt.
Be sure to comment out left-over Mentor stuff from your various dot-files, else this environment script
is designed to fail until you clean up. You can add the “source /vol/ece303/mgc.env” command to
your .cshrc file if you don’t want to type it every time you log in.

4. Create (if necessary) a subdirectory for your mentor files by typing

mkdir ~/MGC
mkdir ~/MGC/ece303

in the shell.

Play with the Design Manager

1. Type “dmgr”.
Notice the transcript that is written to your xterm window. This is a useful place to look to see what
the tool is doing as you perform commands. Also, keep an eye out for errors in this window.
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2. Find the window with a cyan (light blue/green) border.

The default Design Manager window is composed of three sub-windows, two of which are inside the
third. Only one window is active at any given time and the active window is outlined in cyan. Inactive
windows are outlined in gray.

3. Find the File Navigator window

The window in the middle is called the Navigator window and is used to browse the file system. The di-
rectory being displayed is shown in the Navigator window’s title bar. It should always contain ’.../MGC/
right after you start dmgr. Confusingly, the area containing icons on the far right (known as the Palette)
is labeled Navigator at the top. This is the Navigator Palette. Try not to confuse this with the Navigator
window, which has a path name in its title bar.

4. Find the Tools window The window on the left is the Tools window and can be used to invoke Mentor
tools by double clicking the LMB on the appropriate icon.

5. Press and hold the LMB over MGC, near the top left corner of the Design Manager window.

6. While continuing to press the LMB, slide the mouse down until the entry “Setup” is drawn with a box
around it.

7. While continuing to press the LMB, slide the mouse to the right and then down until “Session” is
drawn with a box around it.

8. Let go of the mouse button.

You have just selected a cascade menu. Throughout the tutorial, you will see statements like “Edit→
Change→Name”. This means hold down the LMB on the “Edit” menu, move the mouse down to the
“Change” item, move the mouse to the right until a sub-menu pops up, move the mouse to the “Name”
item, and release the button.

9. Hit the ESC key. In all MGC applications, you can cancel a command that you have not yet completely
entered by hitting ESC. Alternately, most dialog boxes and prompt bars like the one shown have a
Cancel button.

Examine pop up menus.

1. Activate the Navigator window by clicking in its title bar.

2. Press and hold the right mouse button (RMB).

This brings up a pop up menu. The top line of the pop up menu identifies its type. Once you have
popped up a menu, menu operation is identical to that of a pull down menu.

3. Move the mouse outside all menus and release the button.

If the mouse is not pointing within the menu when you release the button, nothing happens.

Throughout the tutorial, you will see statements like “Navigator→Edit→copy”. This means that
you should activate the Navigator window, press the RMB, go to the Edit item, move the mouse right
until a sub-menu appears, go to Copy, and release the RMB.

Become familiar with the Navigator

The navigator is the normal method for starting applications. Moreover, many applications pop up a navigator
window to help you select files to open.
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1. Activate the file Navigator window

2. Press the button with four arrows on it.

3. Enter “/vol/ece303/MGC” into the white box and press the OK button.

The four arrow button allows you to move directly to a directory by typing a path instead of having to
use the up and down arrows.

4. Press the LMB on the “xor”.

This is called selecting. From here on out, we will use the phrase select to indicate you should press
the LMB on the appropriate object. This applies to all MGC tools, windows, and dialog boxes. The
LMB is by far the most used mouse button, so now on, if no button is specified, use the LMB.

5. Press the down arrow icon in the Navigator window. Now, press the up arrow icon.

This moves you into the selected directory.

6. Select the “xor”.

7. Double click on the “xor” folder.

Double clicking on a folder is equivalent to pressing the down arrow icon.

8. Press the up arrow

This is equivalent to the “cd ..” command in Unix, and is the opposite of the down arrow.

9. Press the down arrow.

At the bottom of the Navigator window, you see four buttons with arrows. The down button, when
pushed, goes into the selected subdirectory. The up button goes to the parent directory. The button with
four arrows on it can be used to go to any directory you type in. The right arrow icon can be used to
examine all files referred to by the selected object (don’t worry about this for now).

We’ll provide a few more examples of how to use the Navigator. After that, we’ll simply say, “Select...
using the Navigator,” and leave the details up to you.

10. Close the Tools window.

Use your experience with other window managers to figure out how.

Copy the XOR example.

1. “Windows→Open Navigator”

Remember, this means press the RMB in the “Windows” menu, move the mouse until the “Open
Navigator” entry is highlighted and then release the button. Note that we did not go down into the
sub-menu of “Open Navigator”.

Note that what you get on the RMB pop-up menus is dependent on where the pointer is. To get the
session pop-up, the pointer must over the gray background and not over an active window.

The main window/context of dmgr is called ’Session’, not Design Manager. Mentor is a little incon-
sistent here.

2. Press the four-arrow button. Also called the directory button.

3. Enter “/vol/ece303/MGC”

4. Select the “xor” folder.
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5. “Navigator→Edit→Copy”

6. Put the mouse over the white area following the word “Destination”.

Fields are selected by moving the cursor over them and clicking the LMB. When a field is active, it is
outlined in red.

7. Enter “~/MGC/ece303”.

8. Press the “Options” button.

A dialog box is popped up. If our window is too small, you won’t be able to see the whole thing. You
can either make the main X11 window bigger or you can use the Page Up and Page Down keys. There
are no “page left” and “page right” functions, but moving the mouse will cause the box to scroll.

9. Select “Entire Object” under “Copy Mode” (this should be the default). Use the defaults for the
other modes too.

10. Press “OK” in the “Copy Object Options” dialog box.

11. Press Enter key for prompt bar.

You can usually hit Enter instead of pressing OK. We call this action “Accepting the dialog box”. This
copy will take some time to complete. When it is done, it will display an informational comment at
the bottom of the dmgr graphic window to that effect.

Design the XOR gate.

1. Activate the “$HOME/MGC/ece303” Navigator window.

If you lost it, you can always navigate back to your directory using the 4-way arrow button.

2. “Navigator→Update Window”.

3. Close the “/vol/ece303/MGC” “Navigator” window

Skip this step if you have no such window to close.

4. Select the “xor” component.

This opens the XOR schematic.

5. “Navigator→Open→design arch.”

You will get a warning stating that the sheet has not been checked successfully. Anytime you open an
application from dmgr, two windows will appear: a text window and a graphic window. Most commands
you enter in the graphic window show as text in the text window. Error and status messages go to the
text window and the most recent message is also displayed at the bottom of the graphic window. The
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text window may be closed, but it is recommended that you keep it to view any error messages. It can
also be iconified to get it out of the way. The Design Manager does not have a separate text window;
it uses the window you started it from.

6. Press the maximize button for the schematic window.

This will eventually be the top level design, once all the missing pieces are filled in. All the data you
copied is partially complete and will not start out looking exactly like the figures.

7. Type Shift-F8

This is a View All command. At the bottom of the screen, you’ll notice a map of the function keys.
These provide shortcuts to many commands.

8. Press the RMB in one of the scroll bars of the schematic window and select “View Area”.

9. Drag the LMB in the schematic window to create a rectangle.

Your viewpoint changes to the specified rectangle.

10. Zoom out to view the entire schematic.

11. You can iconify the XOR schematic by clicking the window widget with a small square in it. You can
bring it back later by clicking on the resulting icon.

12. Restore it.

13. View All.

In general, if you make a mistake, you can undo it by using the “Undo” option in the menu. Usually,
the last three changes are remembered. However, some commands destroy the undo stack. If you make
a mistake from here on out, we will assume you will undo it and try again.

14. Find the schematic palette in the center on the right.

15. Make sure you’re in the “Add/Route” menu at the top.

There are four menu titles at the top in red. The active one is highlighted.

16. Press the right arrow on the scroll bar at the bottom of the schematic window.

17. “Libraries→MGC Digital Libraries→Display Libraries Palette.”

18. Select “gen lib”.

Select Libraries from the menu bar, not the schematic palette.

19. Point the mouse in the “gen lib” palette and use the Page Up and Page Down keys until “portout”
shows in the palette.

You can also hit “ Palette→Show Scroll Bars” and drag the bar with the LMB if you think it would
be faster.

20. Click on portout and move the mouse back into the schematic window.

21. Place the shadow port so that the center of the ’+’ is on the end of the output net.

22. “Palette→Back.”

“Selecting entries moves you into libraries. Back moves you out.”

23. “Palette→Display Schematic Palette.”

You can use this command so you don’t have to use Back through many layers of library menus.
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24. Point in the schematic window and press the “F2” key.

Look at the function key map. “F2” executes the command “Unselect All” in the active window.
Objects in white dashed lines are selected. Many commands like “Copy” and “Move” act on the current
selection. In the upper left hand corner under the main menu bar is the label “Sel”, a number, and
possibly a “+”. The number is the number of currently selected objects. The “+” indicates that selecting
another object will add to the set of selected objects. If there is no “+”, selecting an object will unselect
everything and then select the new object.

25. Point at the NET text and press the F1 key.

26. If the text did not select but something else did, press “F2” and try again until the text alone is
selected.

In general, most selection commands (for example, just selecting with the LMB in the schematic win-
dow) will not select property text such as a net name or transistor lengths and widths. F1 is an
exception; it executes a “Select Anything” command.

27. “Schematic→Change Values”.

Notice that when you hit the RMB, a menu titled “Property/Text” appeared. The schematic window
opens menus depending on what you have selected.

28. Point at the word “NET” in the “New Value” field.

29. Click, backspace three times, type “C”, and hit Enter.

30. Press “F2”.

31. Hold the RMB.

Notice an “Add” menu appears when nothing is selected.

32. View All.

33. “Libraries→MGC Digital Libraries→Display Libraries Palette.”

Select libraries from the menu bar, not the schematic palette.

34. Select “gen lib”.

35. Point the mouse in the “gen lib” palette and use the “Page Up” and “Page Down” keys until “nand2”
shows in the palette.

You can also hit “ Palette→Show Scroll Bars” and drag the bar with the LMB if you think it would
be faster.

36. Click on “nand2” and move the mouse back into the schematic window.

37. Place it so its two inputs touch the two wires coming straight out of the “A” and “B” ports.

38. Press the RMB in the schematic window and select the “Copy” menu entry.

39. Place the second gate such that the upper pin is attached to the upper wire in the sheet.

40. Place the third NAND such that the lower pin is attached to the lower wire.

41. Place the final NAND such that the output is attached to the output wire.

42. Hit “ESC”.

You can use “Undo” from within the “Copy” command. It undoes the last placement but keeps you in
“Copy”.
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43. “Palette→Display Schematic Palette.”

44. Press “Connect All” in the schematic and route menu, if necessary.

This takes any wires which touch ports but are not electrically connected and “solders” them.

45. “View All”.

46. If the grid does not show, make your window bigger and “View All” again.

47. Push the “Add Wire” button.

48. Point the mouse at the output pin of the leftmost NAND gate and click the LMB.

49. Move the mouse to the right and click the LMB.

50. Move the mouse straight up until it is directly to the left of the lower pin on the topmost NAND gate
and click the LMB.

51. Move the mouse to the pin and double click the LMB.

52. Move to the top pin of the lowest NAND gate and click the LMB.

53. Move to the left until under the left gate’s output and click the LMB.

54. Move straight up until the mouse points at the place where the output of the previous net turns upward
and double click the LMB.

55. Wire up the final two nets in a similar manner.

It is not considered good style to use diagonal nets.

56. Hit “ESC” to end the “Add Wire” command.

You may need to press “Connect All” in the schematic and route menu again.

Check the schematic

1. “Check→Sheet”.

There should be no errors or warnings. All schematic sheets should be checked before they are saved.
If you save a schematic without checking it, you will get an error if you try to read it using other tools.

2. Close the “Report” window.

3. “Check→Schematic”.

There should be no errors. However, there may be interface warnings. A schematic can have multiple
sheets. When you check a schematic, all sheets are checked and then inter-sheet connectivity is checked.

4. Close the “Report” window.

5. “File→Save Sheet”.

Create and check the symbol.

1. “Miscellaneous→Generate Symbol”.
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2. Choose “Yes” for “Replace existing” option and press “OK”.

The symbol sheet will be opened using input pins “A” and “B” and outpin “C”.

3. “Check→With Defaults”.

There will be some warning.

4. Close the “Report” window.

5. “File→Save Symbol”.

Copying an existing symbol in this manner is one of the easiest methods of creating new symbols. Its
very nice for things that are hard to draw correctly, i.e. symbols with curves in them.

6. “Check→With Defaults”.

There should be no warnings.

7. Close the report and symbol sheets.

8. Go back to the XOR schematic sheet.

9. “Check→Sheet”.

There should be no error or warnings.

10. “Check→Schematic”.

There should be no error or warnings.

11. “File→Save Sheet”.

12. Close the schematic sheet.

13. Close the Design Architect window.

Create a design viewpoint for digital simulation.

Now that we have a schematic and symbol, we want to simulate it to make sure it is right before creating
other circuits that use it. In general, you always want to test small blocks of your design in isolation. If you
wait until you have a large design, it will be difficult to debug.

1. Bring the Design Manager window to the top of the desktop.

2. Select your XOR component.

3. “Navigator→Open→DVE”.

Dve is the Design Viewpoint Editor.

4. “Setup→(Quick)Sim, Fault, Path, and Grade”.

This sets up the generic information needed by QuickSimII, the digital simulator.

5. “Edit→Add→Primitive”.

6. Enter “model” in the “Name” field.

7. “File→Save Design Viewpoint→Save As”.
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8. Enter “digital” in the dialog box and accept it.

You should get a message saying “Removed empty viewpoint: default”. Dve creates a viewpoint called
default if a name isn’t specified when it is first created. When you saved the viewpoint as “digital”, the
empty default was deleted.

9. “File→Close Design Viewpoint”.

This closes the digital viewpoint of the XOR gate we just created for QuickSimII.

10. Close DVE.

This step is optional, but recommended. Keeping all MGC applications open at all times may cause
problems or may slow down your work. You may not want to keep too many unneeded applications (like
dve) open when not in use. It bogs down your machine, and more importantly uses valuable licenses
for various tools.

Digitally simulate the XOR gate

1. If the xor folder in the File Navigator hasn’t been opened, double click it with the LMB.

2. Select the “Digital Viewpoint” object in the “Navigator” window.

3. “Navigator→Open→QuickSimII”.

4. “File→Check Design”.

5. Select “Simulation Checks? Yes” and “Expand Messages? Yes”.

6. Accept the dialog box.

There should not be any warnings or errors. It is a good idea to check your design every time you start
QuickSimII.

7. “Setup→Kernel”.

8. Press “Visible”.

9. Select the “Change” button next to the phrase “Timing Mode”.

10. Select “Full Delays: Min”.

11. Press “Hidden” and accept the dialog box.

This sets the timing mode and should be done each time you start the simulator.

12. “Quicksim→Open→Sheet”.

13. Select the port objects for “A”, “B”, and “C”.

This actually selects the nets that the ports are attached to.

14. “Quicksim→Add→Traces”.

15. If necessary, expand the Traces window so that you can see all three of the values.

16. “Quicksim→Force→Clock”.
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17. Enter the following information and accept the dialog box:
Signal name: A
Period: 100n
Times are absolute
Force type: fixed

“A” isn’t really a clock. In this context, ’clock’ means a periodic waveform.

18. Bring up the “Stimulus” menu from the palette on the right

19. Press the “Add Clock” button to create a force for “B” with the same information as “A” with the
exception of specifying a period of “50 n”.

20. With the mouse in any of the QuickSimII windows, type “init 0r” (zero–r, not o–r) and hit Enter.

You could have executed this command from the menus, but you can also type commands in directly.
All menu commands have a form that can be typed in. Which form you use is entirely up to you.

21. With the mouse in any of the QuickSimII windows, type “run 10” and hit Enter.

22. “Quicksim→Run→Reset”.

23. Choose “State”, unselect “Save results Waveform DB”, and accept the dialog box.

This resets the simulation time to zero. If you don’t execute this, future run commands continue from
the current state. Force commands are also relative to the current time, so you will usually want to
reset the simulation before modifying a force.

24. With the mouse in any of the QuickSimII windows, type “init 0r” and hit Enter.

This initializes the simulator for a run. You need to execute the init command every time you are
going to use the run command and the current time is 0, i.e., on the first run command or when you
have just executed “Run→Reset→State”.

25. Type “run 100” and hit Enter.

The number given to run is always in nanoseconds. Don’t type “run 100n”. The simulation should be
correct for an XOR gate.

26. Close QuickSimII, selecting the “Without saving” button from the exit dialog box.

While it is often useful to keep applications like Design Architect and Design Manager open at all times,
it is not as useful to keep the simulators open since you can’t switch the current design. Note that the
text window that dmgr created for QuickSimII did not go away. All applications started by dmgr run
this way. This allows you to keep windows containing errors up after an application has terminated.

27. Close the QuickSimII text window.

You have finished most of the lab.

3 Deliverables

The following items should be turned in:

1. A sheet plot of your circuit generated in this. You can send this to the printer in the Wilkinson Lab
by opening the XOR gate with Design Architect and going selecting “File→Print Sheet”. Use the
“mgc laser1” printer name. If a prompt asks for a default printer, also use “mgc laser1”.
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2. A simulation trace of your XOR circuit generated in the Tutorial. For this and future assignments, a
plot of the trace window (not the lists window) should be turned in. This process is similar to printing
the schematic. Also use the “mgc laser1” printer name.

Each sheet plot should be labeled with your name, instructor’s name, and the course number.

A Printing to a file

If you want to store the deliverables in PDF files and print them on printers outside the Wilkinson Lab, you
can select “File→Export Graphics” instead of “File→Print Sheet”. Select the EPS format, enter the
pathname of the file you would like to generate. To drop the file in your home directory, use “˜/sheet1.ps”.
Print in “Monochrome” mode instead of “Color” mode.

The process for generating a file for the simulation trace is similar. Once you open the “Print” dialog for
the trace, select the “Export Graphic” button.

Once you have EPS files, you can include them within other documents. However, the EPS files produced
in this way have no margins. If you print them from a PostScript viewer, like “gv”, a portion near the edge
will not appear on the printout. However, there is a workaround. You can convert the EPS files to to PDF
files using the “ps2pdf” command, e.g., “ps2pdf sheet1.eps sheet1.pdf”, and print them from Acrobat
Reader (“acroread sheet1.pdf”).

B Using a remote machine

This section is for people who know a little about X11. If it doesn’t make sense, you can always physically
go to the Wilkinson Lab to do your work.

You can run “dmgr” from any machine with X11 and SSH. That includes almost all Unix (linux) machines,
as well as some Windows machines. However, there is one catch. You’ll need to copy ECE filesystem’s

/vol/MGC 2002/registry/fonts

directory to your local machine and add it to you fontpath by running

mkfontdir <path>
xset +fp <path>
xset fp rehash

Once things work smoothly, you can add the new font path to your X11 configuration file so you don’t need
to run “xset” every time you start X11.

Note that EECS does not have a fontserver set up. Therefore, you’ll need to copy the fonts to your local
machine if the directory isn’t NFS mounted. Once the fonts are moved over, things should work smoothly.
I did the lab via SSH on a Linux box at my apartment.
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